$re = '/^(https?:)?\/\/tags\.tiqcdn\.com\//m';
$str = 'https://tags.tiqcdn.com/x
//tags.tiqcdn.com/x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);