const regex = /^(?:(?:1[6-9]|[2-9]\d)?\d{2})(?:(?:(\/|-|\.)(?:0?[13578]|1[02])\1(?:31))|(?:(\/|-|\.)(?:0?[13-9]|1[0-2])\2(?:29|30)))$|
^(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))(\/|-|\.)0?2\3(?:29)$|
^(?:(?:1[6-9]|[2-9]\d)?\d{2})(\/|-|\.)(?:(?:0?[1-9])|(?:1[0-2]))\4(?:0?[1-9]|1\d|2[0-8])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:1[6-9]|[2-9]\\d)?\\d{2})(?:(?:(\\\/|-|\\.)(?:0?[13578]|1[02])\\1(?:31))|(?:(\\\/|-|\\.)(?:0?[13-9]|1[0-2])\\2(?:29|30)))$|
^(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))(\\\/|-|\\.)0?2\\3(?:29)$|
^(?:(?:1[6-9]|[2-9]\\d)?\\d{2})(\\\/|-|\\.)(?:(?:0?[1-9])|(?:1[0-2]))\\4(?:0?[1-9]|1\\d|2[0-8])$', 'gm')
const str = `2020-01-31
1989-3-31
1989-01-30
2020-03-29
2020-02-29
2020-2-29
2017-04-09
2021-05-31
2021
jnnij
14
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}