# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"administrator"
test_str = ("{\n"
" \"switch_themes\":true,\n"
" \"edit_themes\":true,\n"
" \"activate_plugins\":true,\n"
" \"edit_plugins\":true,\n"
" \"edit_users\":true,\n"
" \"edit_files\":true,\n"
" \"manage_options\":true,\n"
" \"moderate_comments\":true,\n"
" \"manage_categories\":true,\n"
" \"manage_links\":true,\n"
" \"upload_files\":true,\n"
" \"import\":true,\n"
" \"unfiltered_html\":true,\n"
" \"edit_posts\":true,\n"
" \"edit_others_posts\":true,\n"
" \"edit_published_posts\":true,\n"
" \"publish_posts\":true,\n"
" \"edit_pages\":true,\n"
" \"read\":true,\n"
" \"level_10\":true,\n"
" \"level_9\":true,\n"
" \"level_8\":true,\n"
" \"level_7\":true,\n"
" \"level_6\":true,\n"
" \"level_5\":true,\n"
" \"level_4\":true,\n"
" \"level_3\":true,\n"
" \"level_2\":true,\n"
" \"level_1\":true,\n"
" \"level_0\":true,\n"
" \"edit_others_pages\":true,\n"
" \"edit_published_pages\":true,\n"
" \"publish_pages\":true,\n"
" \"delete_pages\":true,\n"
" \"delete_others_pages\":true,\n"
" \"delete_published_pages\":true,\n"
" \"delete_posts\":true,\n"
" \"delete_others_posts\":true,\n"
" \"delete_published_posts\":true,\n"
" \"delete_private_posts\":true,\n"
" \"edit_private_posts\":true,\n"
" \"read_private_posts\":true,\n"
" \"delete_private_pages\":true,\n"
" \"edit_private_pages\":true,\n"
" \"read_private_pages\":true,\n"
" \"delete_users\":true,\n"
" \"create_users\":true,\n"
" \"unfiltered_upload\":true,\n"
" \"edit_dashboard\":true,\n"
" \"update_plugins\":true,\n"
" \"delete_plugins\":true,\n"
" \"install_plugins\":true,\n"
" \"update_themes\":true,\n"
" \"install_themes\":true,\n"
" \"update_core\":true,\n"
" \"list_users\":true,\n"
" \"remove_users\":true,\n"
" \"promote_users\":true,\n"
" \"edit_theme_options\":true,\n"
" \"delete_themes\":true,\n"
" \"export\":true,\n"
" \"edit_rcb-cookie\":true,\n"
" \"read_rcb-cookie\":true,\n"
" \"delete_rcb-cookie\":true,\n"
" \"edit_rcb-cookies\":true,\n"
" \"edit_others_rcb-cookies\":true,\n"
" \"publish_rcb-cookies\":true,\n"
" \"read_private_rcb-cookies\":true,\n"
" \"delete_rcb-cookies\":true,\n"
" \"delete_private_rcb-cookies\":true,\n"
" \"delete_published_rcb-cookies\":true,\n"
" \"delete_others_rcb-cookies\":true,\n"
" \"edit_private_rcb-cookies\":true,\n"
" \"edit_published_rcb-cookies\":true,\n"
" \"edit_rcb-blocker\":true,\n"
" \"read_rcb-blocker\":true,\n"
" \"delete_rcb-blocker\":true,\n"
" \"edit_rcb-blockers\":true,\n"
" \"edit_others_rcb-blockers\":true,\n"
" \"publish_rcb-blockers\":true,\n"
" \"read_private_rcb-blockers\":true,\n"
" \"delete_rcb-blockers\":true,\n"
" \"delete_private_rcb-blockers\":true,\n"
" \"delete_published_rcb-blockers\":true,\n"
" \"delete_others_rcb-blockers\":true,\n"
" \"edit_private_rcb-blockers\":true,\n"
" \"edit_published_rcb-blockers\":true,\n"
" \"edit_rcb-tcf-vendor-conf\":true,\n"
" \"read_rcb-tcf-vendor-conf\":true,\n"
" \"delete_rcb-tcf-vendor-conf\":true,\n"
" \"edit_rcb-tcf-vendor-confs\":true,\n"
" \"edit_others_rcb-tcf-vendor-confs\":true,\n"
" \"publish_rcb-tcf-vendor-confs\":true,\n"
" \"read_private_rcb-tcf-vendor-confs\":true,\n"
" \"delete_rcb-tcf-vendor-confs\":true,\n"
" \"delete_private_rcb-tcf-vendor-confs\":true,\n"
" \"delete_published_rcb-tcf-vendor-confs\":true,\n"
" \"delete_others_rcb-tcf-vendor-confs\":true,\n"
" \"edit_private_rcb-tcf-vendor-confs\":true,\n"
" \"edit_published_rcb-tcf-vendor-confs\":true,\n"
" \"loco_admin\":true,\n"
" \"manage_woocommerce\":true,\n"
" \"view_woocommerce_reports\":true,\n"
" \"edit_product\":true,\n"
" \"read_product\":true,\n"
" \"delete_product\":true,\n"
" \"edit_products\":true,\n"
" \"edit_others_products\":true,\n"
" \"publish_products\":true,\n"
" \"read_private_products\":true,\n"
" \"delete_products\":true,\n"
" \"delete_private_products\":true,\n"
" \"delete_published_products\":true,\n"
" \"delete_others_products\":true,\n"
" \"edit_private_products\":true,\n"
" \"edit_published_products\":true,\n"
" \"manage_product_terms\":true,\n"
" \"edit_product_terms\":true,\n"
" \"delete_product_terms\":true,\n"
" \"assign_product_terms\":true,\n"
" \"edit_shop_order\":true,\n"
" \"read_shop_order\":true,\n"
" \"delete_shop_order\":true,\n"
" \"edit_shop_orders\":true,\n"
" \"edit_others_shop_orders\":true,\n"
" \"publish_shop_orders\":true,\n"
" \"read_private_shop_orders\":true,\n"
" \"delete_shop_orders\":true,\n"
" \"delete_private_shop_orders\":true,\n"
" \"delete_published_shop_orders\":true,\n"
" \"delete_others_shop_orders\":true,\n"
" \"edit_private_shop_orders\":true,\n"
" \"edit_published_shop_orders\":true,\n"
" \"manage_shop_order_terms\":true,\n"
" \"edit_shop_order_terms\":true,\n"
" \"delete_shop_order_terms\":true,\n"
" \"assign_shop_order_terms\":true,\n"
" \"edit_shop_coupon\":true,\n"
" \"read_shop_coupon\":true,\n"
" \"delete_shop_coupon\":true,\n"
" \"edit_shop_coupons\":true,\n"
" \"edit_others_shop_coupons\":true,\n"
" \"publish_shop_coupons\":true,\n"
" \"read_private_shop_coupons\":true,\n"
" \"delete_shop_coupons\":true,\n"
" \"delete_private_shop_coupons\":true,\n"
" \"delete_published_shop_coupons\":true,\n"
" \"delete_others_shop_coupons\":true,\n"
" \"edit_private_shop_coupons\":true,\n"
" \"edit_published_shop_coupons\":true,\n"
" \"manage_shop_coupon_terms\":true,\n"
" \"edit_shop_coupon_terms\":true,\n"
" \"delete_shop_coupon_terms\":true,\n"
" \"assign_shop_coupon_terms\":true,\n"
" \"wpml_manage_translation_management\":true,\n"
" \"wpml_manage_languages\":true,\n"
" \"wpml_manage_theme_and_plugin_localization\":true,\n"
" \"wpml_manage_support\":true,\n"
" \"wpml_manage_woocommerce_multilingual\":true,\n"
" \"wpml_operate_woocommerce_multilingual\":true,\n"
" \"wpml_manage_media_translation\":true,\n"
" \"wpml_manage_navigation\":true,\n"
" \"wpml_manage_sticky_links\":true,\n"
" \"wpml_manage_string_translation\":true,\n"
" \"wpml_manage_translation_analytics\":true,\n"
" \"wpml_manage_wp_menus_sync\":true,\n"
" \"wpml_manage_taxonomy_translation\":true,\n"
" \"wpml_manage_troubleshooting\":true,\n"
" \"wpml_manage_translation_options\":true,\n"
" \"wpgmp_admin_overview\":true,\n"
" \"wpgmp_how_overview\":true,\n"
" \"wpgmp_form_location\":true,\n"
" \"wpgmp_manage_location\":true,\n"
" \"wpgmp_form_map\":true,\n"
" \"wpgmp_manage_map\":true,\n"
" \"wpgmp_form_group_map\":true,\n"
" \"wpgmp_manage_group_map\":true,\n"
" \"wpgmp_manage_settings\":true,\n"
" \"wpgmp_manage_extentions\":true,\n"
" \"wp-piwik_read_stats\":true,\n"
" \"manage_instagram_feed_options\":true,\n"
" \"edit_dzsap_items\":true,\n"
" \"edit_others_dzsap_items\":true,\n"
" \"rank_math_edit_htaccess\":true,\n"
" \"rank_math_titles\":true,\n"
" \"rank_math_general\":true,\n"
" \"rank_math_sitemap\":true,\n"
" \"rank_math_404_monitor\":true,\n"
" \"rank_math_link_builder\":true,\n"
" \"rank_math_redirections\":true,\n"
" \"rank_math_role_manager\":true,\n"
" \"rank_math_analytics\":true,\n"
" \"rank_math_site_analysis\":true,\n"
" \"rank_math_onpage_analysis\":true,\n"
" \"rank_math_onpage_general\":true,\n"
" \"rank_math_onpage_advanced\":true,\n"
" \"rank_math_onpage_snippet\":true,\n"
" \"rank_math_onpage_social\":true,\n"
" \"rank_math_admin_bar\":true,\n"
" \"frm_view_forms\":true,\n"
" \"frm_edit_forms\":true,\n"
" \"frm_delete_forms\":true,\n"
" \"frm_change_settings\":true,\n"
" \"frm_view_entries\":true,\n"
" \"frm_delete_entries\":true,\n"
" \"administrator\":true,\n"
" \"manage_translations\":true,\n"
" \"install_languages\":true,\n"
" \"resume_plugins\":true,\n"
" \"resume_themes\":true,\n"
" \"view_site_health_checks\":true,\n"
" \"view_query_monitor\":true\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.