$re = '/^(?!\d{6}$)[a-zA-Z0-9]+$/m';
$str = '1234567
a123456
123456P
3A237bdb8
123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);