use strict;
my $str = '# Project Overview
Welcome to the project overview document. This document provides a summary of the project, including key milestones and team members.
## Key Milestones
The following table outlines the key milestones for the project:
| Milestone | Description | Due Date |
|-----------------|--------------------------------------|------------|
| Project Kickoff | Initial project meeting | 2024-06-01 |
| Phase 1 | Completion of the first development phase | 2024-07-15 |
| Testing | Start of the testing phase | 2024-08-01 |
| Launch | Official project launch | 2024-09-01 |
## Team Members
Below is a table listing the team members involved in the project:
| Name | Role | Contact Email |
|-----------------|---------------------|------------------------|
| Alice Johnson | Project Manager | alice.johnson@example.com |
| Bob Smith | Lead Developer | bob.smith@example.com |
| Carol White | QA Engineer | carol.white@example.com |
| David Brown | UX Designer | david.brown@example.com |
';
my $regex = qr/^\|.*\|\n\|\s*[:-]+.*\n(?:\|.*\|\n)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}