$re = '/(ip|ec2)-((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)-){3}(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))($|(?:ec2|[^.]+\.compute)\.internal\.$)?/m';
$str = 'us-west-2.elasticmapreduce.amazonaws.com
ip-10-27-87-173
ip-10-27-91-145.us-west-2.compute.internal
ip-10-27-90-170.us-west-2.compute.internal.us-west-2.compute.internal
ec2-54-82-117-121
ec2-54-82-117-121.compute-1.amazonaws.com
ec2-54-82-117-121.compute-1.amazonaws.com.us-west-2.compute.internal
ip-10-27-102-175.us-west-2.compute.internal.us-west-2.compute.internal
ip-10-27-180-213.us-west-2.compute.internal
ip-10-27-107-136.us-west-2.compute.internal.us-west-2.compute.internal
ip-10-27-209-104.us-east-1.compute.internal
ip-10-27-209-104.us-east-1.compute.internal.us-east-1.compute.internal
ip-10-27-209-104.us-east-1.compute.internal.ec2.internal
ip-10-27-112-164.ec2.internal
ip-255-27-112-164.ec2.internal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);