$re = '/^.*youtube\.com((?!\/user\/|\/channel\/).)*$/m';
$str = 'https://www.youtube.com/feed/trending
https://www.youtube.com/user/whateva/featured
https://www.youtube.com/channel/lfjafjsldsf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);