$re = '/([0-9]+)/m';
$str = 'host1
ho12st
host
host2
host2test
host02
host34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);