$re = '/^(?<device>[^ ]+)(\s+[^ ]+){4}\s+(?<disk>\d+)/m';
$str = '/dev/nvme4n1p1 xfs 50G 555M 50G 2% 25M 33K 25M 1% /var/www
/dev/mapper/group1-mountpoint_www xfs 9.0G 674M 8.4G 8% 4.5M 33K 4.5M 1% /var/www';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);