$re = '/(?<=\/)\d{1,4}(?=\/)/';
$str = 'https://pokeapi.co/api/v2/ability/35/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);