$re = '/\d+\b(?!€)/m';
$str = '100
200€
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);