import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div(.*?)class=\\\"(.*?)articlePage\\\">(.*?)<\\/div>";
final String string = " <div class=\"WYSIWYG articlePage\">\n"
+ " <div id=\"imgCarousel\" class=\"imgCarousel\">\n"
+ " <img alt=\"Cредний курс покупки/продажи наличного доллара в банках Москвы на 10:00 мск составил 78,13/99 руб.\" id=\"carouselImage\" src=\"https://i-invdn-com.investing.com/news/moved_LYNXMPEHAG0NK_L.jpg\" style=\"visibility:hidden\">\n"
+ " <span class=\"text\">© Reuters Cредний курс покупки/продажи наличного доллара в банках Москвы на 10:00 мск составил 78,13/99 руб.</span>\n"
+ " <i class=\"imgGrad\"></i>\n"
+ " </div>\n"
+ " По состоянию на 10:00 мск на основе информации, предоставленной банками и обменными пунктами Москвы, Cредний курс покупки/продажи наличного доллара составил 78,13/99 <span class=\"aqPopupWrapper js-hover-me-wrapper\"><a href=\"/currencies/usd-rub\" id=\"6244069225ed1\" class=\"aqlink js-hover-me\" hoverme=\"aql\" data-pairid=\"2186\">руб. за доллар</a></span>. По сравнению с предыдущим днем Cредний курс покупки упал на 208 коп., Cредний курс продажи упал на 1492 коп.</p>\n"
+ " <p> Лучшие курсы покупки составили 84-83,9 руб. за доллар, лучшие курсы продажи 99-99,1 руб. за доллар.</p>\n"
+ " <p> Это автоматическое сообщение.</p> <div class=\"clear\"></div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}