$re = '/^(?!.*xxxx.*)(?=.*en\/?$).*/m';
$str = 'https://xxxx.yyyy.com/en
https://xxx.yyyy.com/en
https://xxx.yyyy.com/en/more/here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);