re = /^(?!.*xxxx)(?=.*\/en(?:$|\/)).*/m
str = 'https://xxxx.yyyy.com/en
https://xxx.yyyy.com/en
https://xxx.yyyy.com/en/
https://xxx.yyyy.com/en/foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end