#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d(?=(?:-?\d){7}-?\d-\d$)\d*-\d+-\d*\d-\d$"
Local $sString = "01-234-5678-9" & @CRLF & _
"01234-56-78-9" & @CRLF & _
"0123-4-5678-9" & @CRLF & _
"012-345-678-9" & @CRLF & _
"01-234567-8-9" & @CRLF & _
"01-234-5678-9" & @CRLF & _
"0-12345-678-9" & @CRLF & _
"0-123-45678-9" & @CRLF & _
"0-123-45678-9" & @CRLF & _
"01-23456-78-9" & @CRLF & _
"0-123456-78-9" & @CRLF & _
"0-1234567-8-9" & @CRLF & _
"No Match:" & @CRLF & _
"" & @CRLF & _
"01-234-56788-9" & @CRLF & _
"01-234-568-9" & @CRLF & _
"01--2345678-9" & @CRLF & _
"01-2345678--9" & @CRLF & _
"0-1-23456789" & @CRLF & _
"-01-2345678-9" & @CRLF & _
"" & @CRLF & _
"0-1238787456-78-9" & @CRLF & _
"0-123456-78-3439" & @CRLF & _
"0-123456-738-9" & @CRLF & _
"30-123456-78-9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")