package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((param\d{1}\s?\=)(\s?))([a-z0-9\"\'\=]{3,10})`)
var str = `param1=abc
param2 = abc
param3 = "ab'c"
param4='a"b"c'
param5="abc=def"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}