// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((param\d{1})(\s?\=)(\s?))([a-z0-9\"\'\=]{3,10})"#).unwrap();
let string = "param1=abc
param2 = abc
param3 = \"ab'c\"
param4='a\"b\"c'
param5=\"abc=def\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}