package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z])([A-Z])`)
var str = `abcABC`
var substitution = "$1,$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}