$re = '/^(\d)(?!\1+$)\d{5}$/m';
$str = '000000
000001
111110';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);