$re = '/^(?:\d{1,5}|(?=\d*\.\d+$)(?=.{2,6}$)[\d.]*)$/m';
$str = '1.2
24.232
24.2344
1.2345
1.23566
12345
123456
.12345
0.2452
2..2
..
.
22.
.22
2..42
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);