const regex = /(?<=^|&)(.*?=.*?)(?=&|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|&)(.*?=.*?)(?=&|$)', 'gm')
const str = `address_1=02037cab&target=50+50+1&offset=50+50+1&relay=50+50+1&method=relay&type=gps&sender=0203389e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}