$re = '/(?<=^|&)((?:target|offset|relay|method|type)=.*?)(?=&|$)/m';
$str = 'address_1=02037cab&target=50+50+1&offset=50+50+1&relay=50+50+1&method=relay&type=gps&sender=0203389e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);