package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[aeiou]`)
var str = `a, b, c, d, e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}