$re = '/^(?![\s-])[\w -]+$/m';
$str = 'abc def 123 ___ -loc-
abc def 123 ___ -loc- ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);