$re = '/(?(?=.*?interface GigabitEthernet.*?description\s\d{4}-NNCX.*?isis ldp-sync.*?))(?R)/is';
$str = '#
interface GigabitEthernet1/2/0.2277
description 2400-NNCX8H
isis ldp-sync
#
interface GigabitEthernet1/2/2
negotiation auto
undo shutdown
#
interface GigabitEthernet1/2/2.200
description 2437-ATN91
isis ldp-sync
#
interface GigabitEthernet1/2/5.3660
vlan-type dot1q 3660
description NERH4
#
interface GigabitEthernet1/2/2.200
description 2437-ATN91
isis cost 1000
isis small-hello
isis ldp-sync
#
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);