re = /(User\d+)/m
str = 'Yay you made it, User1 ! — 25/03/2022 --------------- User2 joined the party. — 22/03/2022 --------------- Yay you made it, User3 ! — 29/03/2022 --------------- User4 joined the party. — 28/03/2022'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end