re = /(^a[a-z]+a$)|(^e[a-z]+e$)|(^i[a-z]+i$)|(^o[a-z]+o$)|(^u[a-z]u+$)/m
str = 'agdua'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end