using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_+[^_]+_+[^_]+$";
string input = @"test_test_test_test_test";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}