$re = '/(\w)(?!.*?\1)/m';
$str = '1,2,3,a,b,c,a,b,c,1,2,3,c,b,a,2,3,1,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);