#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)@length(?![\w.-])"
Local $sString = "@length Lorem ipsum dolor sit amet, consetetur sadipscing elitr, @length.article sed diam " & @CRLF & _
"nonumy eirmod tempor invidunt ut labore et dolore magna @length.media aliquyam erat, sed " & @CRLF & _
"diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd " & @CRLF & _
"gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem @length_name " & @CRLF & _
"ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt " & @CRLF & _
"ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et " & @CRLF & _
"justo duo dolores et @length ea rebum. Stet clita kasd gubergren, no sea takimata sanctus " & @CRLF & _
"est Lorem ipsum dolor sit amet. @length"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")