import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@length(?!\\S)";
final String string = "@length Lorem ipsum dolor sit amet, consetetur sadipscing elitr, @length.article sed diam \n"
+ "nonumy eirmod tempor invidunt ut labore et dolore magna @length.media aliquyam erat, sed \n"
+ "diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd \n"
+ "gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem @length_name \n"
+ "ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt \n"
+ "ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et \n"
+ "justo duo dolores et @length ea rebum. Stet clita kasd gubergren, no sea takimata sanctus \n"
+ "est Lorem ipsum dolor sit amet. @length";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}