re = /\bdat\w*\s*wy\.?(\d{4}([-\/ .])\d{2}\2\d{2}|\d{2}([-\/ .])\d{2}\3\d{4})/mi
str = 'abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end