$re = '/\bcarro(?!\<)\b/m';
$str = 'Mi carro es dorado como el <b>carro</b> de enfrente';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);