package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/[^\\\/]+){2}(?:\\\/[^\\\/]+)?`)
var str = `/10/102-\/ABC083.013/11/201201/20/83/30/463098194/32/7.7/40/0:20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}