#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Â|â|Ã|\||©|®|™)"
Local $sString = "Calcaneal Locking Plate â" & @CRLF & _
"Aspen Richard-Allan® Surgical Needle, Keith’s Abdominal Cutting, Straight 0.03 in x 2.244 in" & @CRLF & _
"Laborie T-DOC® Single Sensor Coudé Catheter, Coude Tip 7 Fr" & @CRLF & _
"" & @CRLF & _
"Hydrocellular Foam Dressings SILICONE ADHESIVE | WITH BORDER | Sacral | GENTLE ADHESIVE | STERILE 7" x 7" Dressing 5" x 5" Pad " & @CRLF & _
"" & @CRLF & _
"00612479126886 c1c1a9c5-39a6-4816-8577-256b35dd2908 New Published 1 2018-11-05 2018-10-05 NULL In Commercial Distribution McKesson 16-4063 NULL 023904428 MCKESSON MEDICAL-SURGICAL INC. 96 Gauze Bandage Roll NON-STERILE 6-PLY | 100% COTTON 3.4" x 3.6 Yards false true false false false true true false false false false false true Labeling does not contain MRI Safety Information false false false false FULLDownload_Part95_Of_100_2020-04-01.xml 2020-04-01 Full GUDID load 2020-04-01T04:19:25 2020-04-03 12:46:39.6105233 9999-12-31 23:59:59.9999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")