#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/(soundcloud\.com\/\S+|snd\.sc\/\S+))"
Local $sString = "Some useless text : Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ex rebus enim timiditas, non ex vocabulis nascitur. At miser, si in flagitiosa et vitiosa vita afflueret voluptatibus. Sin dicit obscurari quaedam nec apparere, quia valde parva sint, nos quoque concedimus; Duo Reges: constructio interrete. Qui autem esse poteris, nisi te amor ipse ceperit? Cum ageremus, inquit, vitae beatum et eundem supremum diem, scribebamus haec. Teneo, inquit, finem illi videri nihil dolere. Memini vero, inquam; " & @CRLF & _
"https://soundcloud.com/hummus-records-1/sets/louis-jucker-some-of-the-missing-ones" & @CRLF & _
"" & @CRLF & _
"https://soundcloud.com/hummus-records-1/01-nevborn-sending-a-message?in=hummus-records-1/sets/nevborn" & @CRLF & _
"" & @CRLF & _
"Iubet igitur nos Pythius Apollo noscere nosmet ipsos. Aeque enim contingit omnibus fidibus, ut incontentae sint. An vero, inquit," & @CRLF & _
"https://soundcloud.com/hummus-records-1/sets/schwarz-1 quisquam potest probare, quod perceptfum, quod. Sed ad illum redeo. Sapientem locupletat ipsa natura, cuius divitias Epicurus parabiles esse docuit. Tamen a proposito, inquam, aberramus. Sint modo partes vitae beatae. Duarum enim vitarum nobis erunt instituta capienda." & @CRLF & _
"asd" & @CRLF & _
"http://snd.sc/yp6VMo " & @CRLF & _
"" & @CRLF & _
"http://asd.ch " & @CRLF & _
"asdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")