import re
regex = re.compile(r"^([\w]+[^\w\r\n-]+){2}[\w]+", flags=re.MULTILINE)
test_str = ("Apache Log4j Unsupported Version Detection\n"
"Apache Log4j Unsupported Version Detection\n"
"OpenJDK 7 <= 7u281 / 8 <= 8u272 / 11.0.0 <= 11.0.9 / 13.0.0 <= 13.0.5 / 15.0.0 <= 15.0.1 Vulnerability (2021-01-19)\n"
"Apache Log4j Unsupported Version Detection\n"
"Oracle Java SE 1.7.0_321 / 1.8.0_311 / 1.11.0_13 / 1.17.0_1 Multiple Vulnerabilities (Unix October 2021 CPU)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")