re = /^(?=[^a-z\n]*[a-z])(?=[^A-Z\n]*[A-Z])(?=[^\d]*\d).{8,}$/m
str = 'weak
stronger
Str00nger'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end