re = /([^.?!:;\/]+(?:\.(?=mp3\b)[^.?!:;\/]*)*[.?!:;\/]) ?/m
str = 'Hello! Here is a file. It is called beatles.mp3. And so on!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end