re = /^(?=.*[a-z])(?=.*[0-9])[a-z0-9][a-z0-9_]{1,6}[a-z0-9]$/m
str = '12
he
hello
12345
hello123
user_123
1_a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end