$re = '/-a-([^\?]+)\?/m';
$str = 'location/city/home-a-berlin?/someNewAdress
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);