#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "background-image:\s*(url\((?!data)[^)]+\))"
Local $sString = "background-image: url("img/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url(img/home_bbbbbb_14.png);" & @CRLF & _
"background-image: url(images/home_bbbbbb_14.png);" & @CRLF & _
"background-image: url('images/home_bbbbbb_14.png');" & @CRLF & _
"background-image: url("images/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url(home_bbbbbb_14.png);" & @CRLF & _
"background-image: url('home_bbbbbb_14.png');" & @CRLF & _
"background-image: url("home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("../img/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("./img/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("../../img/home_bbbbbb_14.png");" & @CRLF & _
" background-image: url(data:image/svg+xml;base64,PHN2ZyBmaWxsPSIjMDAwMDAwIiBoZWlnaHQ9IjI0IiB2aWV3Qm94PSIwIDAgMjQgMjQiIHdpZHRoPSIyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4gICAgPHBhdGggZD0iTTAgMGgyNHYyNEgweiIgZmlsbD0ibm9uZSIvPiAgICA8cGF0aCBkPSJNMTIgOGMtMi4yMSAwLTQgMS43OS00IDRzMS43OSA0IDQgNCA0LTEuNzkgNC00LTEuNzktNC00LTR6bS03IDdIM3Y0YzAgMS4xLjkgMiAyIDJoNHYtMkg1di00ek01IDVoNFYzSDVjLTEuMSAwLTIgLjktMiAydjRoMlY1em0xNC0yaC00djJoNHY0aDJWNWMwLTEuMS0uOS0yLTItMnptMCAxNmgtNHYyaDRjMS4xIDAgMi0uOSAyLTJ2LTRoLTJ2NHoiLz48L3N2Zz4=);" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")