#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "url(?:\(\"|\(\'|\(\/?.*\/|\()(\.+)?(\/.*\/)?(\w*)+(.png|.jpg|.gif|.jpeg)"
Local $sString = "(home_bbbbbb_14.png);" & @CRLF & _
"behavior: url(#default#VML);" & @CRLF & _
"background-image: url(home_bbbbbb_14.ttf);" & @CRLF & _
"background-image: url('home.ttf');" & @CRLF & _
"background-image: url('home.png');" & @CRLF & _
"background-image: url(images/home_bbbbbb_14.png);" & @CRLF & _
"background-image: url('images/home_bbbbbb_14.jpeg');" & @CRLF & _
"background-image: url("images/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url(home_bbbbbb_14.png);" & @CRLF & _
"background-image: url('home_bbbbbb$_14.png');" & @CRLF & _
"background-image: url("home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("../img/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("./img/home_bbbbbb_14.png");" & @CRLF & _
"background-image: url("../../img/home_bbbbbb_14.jpg");" & @CRLF & _
"url("images/animated-overlay.gif");" & @CRLF & _
"url("images/ui-bg_flat_75_ffffff_40x100.png");" & @CRLF & _
"url('select2.png');" & @CRLF & _
"url(select2x2.png);" & @CRLF & _
"url('../images/back_enabled.png');" & @CRLF & _
"url('../pic/back_enabled.png');" & @CRLF & _
"" & @CRLF & _
"background-image: url(data:image/svg+xml;base64,PHN2ZyBmaWxsPSIjMDAwMDAwIiBoZWlnaHQ9IjI0IiB2aWV3Qm94PSIwIDAgMjQgMjQiIHdpZHRoPSIyNCIgeG1sbnM9Imh0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnIj4gICAgPHBhdGggZD0iTTAgMGgyNHYyNEgweiIgZmlsbD0ibm9uZSIvPiAgICA8cGF0aCBkPSJNMTIgOGMtMi4yMSAwLTQgMS43OS00IDRzMS43OSA0IDQgNCA0LTEuNzkgNC00LTEuNzktNC00LTR6bS03IDdIM3Y0YzAgMS4xLjkgMiAyIDJoNHYtMkg1di00ek01IDVoNFYzSDVjLTEuMSAwLTIgLjktMiAydjRoMlY1em0xNC0yaC00djJoNHY0aDJWNWMwLTEuMS0uOS0yLTItMnptMCAxNmgtNHYyaDRjMS4xIDAgMi0uOSAyLTJ2LTRoLTJ2NHoiLz48L3N2Zz4=);" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")