# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z_][a-z0-9_-]{0,30}[a-z0-9_$-]?:[^:]*:\d+:\d+:[^:]*:[^:]*:[^:]*$"
test_str = ("root:x:0:0:root:/root:/bin/bash\n"
"daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin\n"
"bin:x:2:2:bin:/bin:/usr/sbin/nologin\n"
"sys:x:3:3:sys:/dev:/usr/sbin/nologin\n"
"sync:x:4:65534:sync:/bin:/bin/sync\n"
"games:x:5:60:games:/usr/games:/usr/sbin/nologin\n"
"man:x:6:12:man:/var/cache/man:/usr/sbin/nologin\n"
"lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin\n"
"mail:x:8:8:mail:/var/mail:/usr/sbin/nologin\n"
"news:x:9:9:news:/var/spool/news:/usr/sbin/nologin\n"
"uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin\n"
"proxy:x:13:13:proxy:/bin:/usr/sbin/nologin\n"
"www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin\n"
"backup:x:34:34:backup:/var/backups:/usr/sbin/nologin\n"
"list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin\n"
"mysql:x:115:124:MySQL Server,,,:/var/lib/mysql:/bin/false\n"
"sshd:x:116:65534::/var/run/sshd:/usr/sbin/nologin\n"
"guest:x:118:125:Guest,,,:/tmp/guest-home.phc17z:/bin/bash\n"
"gordon:x:1004:1000:Assaf Gordon,,,,:/home/gordon:/bin/bash\n"
"charles:x:1005:1000:Charles,,,,:/home/charles:/bin/bash\n"
"alice:x:1006:1000:Alice,,,,:/home/alice:/bin/bash\n"
"bob:x:1007:1000:Bob,,,,:/home/bob:/bin/bash\n"
"postgres:x:119:126:PostgreSQL administrator,,,:/var/lib/postgresql:/bin/bash\n"
"rabbitmq:x:125:138:RabbitMQ messaging server,,,:/var/lib/rabbitmq:/bin/false\n"
"redis:x:126:140:redis server,,,:/var/lib/redis:/bin/false\n"
"postfix:x:127:141::/var/spool/postfix:/bin/false\n\n"
"root::0:0:root:/root:/bin/sh\n"
"bin:*:1:1:bin:/bin:/bin/false\n"
"daemon:*:2:2:daemon:/sbin:/bin/false\n"
"adm:*:3:4:adm:/var/account:/bin/false\n"
"lp:*:4:7:lp:/var/spool/lpd:/bin/false\n"
"sync:*:5:0:sync:/sbin:/bin/sync\n"
"shutdown:*:6:0:shutdown:/sbin:/sbin/shutdown\n"
"halt:*:7:0:halt:/sbin:/sbin/halt\n"
"mail:*:8:12:mail:/var/mail:/bin/false\n"
"news:*:9:13:news:/home/services/news:/bin/false\n"
"uucp:*:10:14:uucp:/var/spool/uucp:/bin/false\n"
"operator:*:11:0:operator:/root:/bin/false\n"
"games:*:12:20:games:/usr/games:/bin/false\n"
"ftp:*:14:50:FTP User:/home/services/ftp:/bin/false\n"
"http:*:51:51:HTTP User:/home/services/httpd:/bin/false\n"
"stats:*:123:123:Statistics generator user:/usr/share/empty:/bin/false\n"
"nobody:*:99:99:Nobody:/usr/share/empty:/bin/false\n\n"
"root:x:0:0:root:/root:/bin/bash\n"
"bin:x:1:1:bin:/bin:/sbin/nologin\n"
"daemon:x:2:2:daemon:/sbin:/sbin/nologin\n"
"adm:x:3:4:adm:/var/adm:/sbin/nologin\n"
"lp:x:4:7:lp:/var/spool/lpd:/sbin/nologin\n"
"sync:x:5:0:sync:/sbin:/bin/sync\n"
"shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown\n"
"halt:x:7:0:halt:/sbin:/sbin/halt\n"
"mail:x:8:12:mail:/var/spool/mail:/sbin/nologin\n"
"news:x:9:13:news:/etc/news:\n"
"uucp:x:10:14:uucp:/var/spool/uucp:/sbin/nologin\n"
"operator:x:11:0:operator:/root:/sbin/nologin\n"
"games:x:12:100:games:/usr/games:/sbin/nologin\n"
"gopher:x:13:30:gopher:/var/gopher:/sbin/nologin\n"
"ftp:x:14:50:FTP User:/var/ftp:/sbin/nologin\n"
"nobody:x:99:99:Nobody:/:/sbin/nologin\n"
"nscd:x:28:28:NSCD Daemon:/:/sbin/nologin\n"
"vcsa:x:69:69:virtual console memory owner:/dev:/sbin/nologin\n"
"pcap:x:77:77::/var/arpwatch:/sbin/nologin\n"
"ntp:x:38:38::/etc/ntp:/sbin/nologin\n"
"dbus:x:81:81:System message bus:/:/sbin/nologin\n"
"avahi:x:70:70:Avahi daemon:/:/sbin/nologin\n"
"rpc:x:32:32:Portmapper RPC user:/:/sbin/nologin\n"
"apache:x:48:48:Apache:/var/www:/sbin/nologin\n"
"mailnull:x:47:47::/var/spool/mqueue:/sbin/nologin\n"
"smmsp:x:51:51::/var/spool/mqueue:/sbin/nologin\n"
"hsqldb:x:96:96::/var/lib/hsqldb:/sbin/nologin\n"
"sshd:x:74:74:Privilege-separated SSH:/var/empty/sshd:/sbin/nologin\n"
"rpcuser:x:29:29:RPC Service User:/var/lib/nfs:/sbin/nologin\n"
"nfsnobody:x:65534:65534:Anonymous NFS User:/var/lib/nfs:/sbin/nologin\n"
"xfs:x:43:43:X Font Server:/etc/X11/fs:/sbin/nologin\n"
"haldaemon:x:68:68:HAL daemon:/:/sbin/nologin\n"
"avahi-autoipd:x:100:102:avahi-autoipd:/var/lib/avahi-autoipd:/sbin/nologin\n"
"gdm:x:42:42::/var/gdm:/sbin/nologin\n"
"jackhuang:x:501:501::/home/jackhuang:/bin/bash\n"
"mysql:x:27:27:MySQL Server:/var/lib/mysql:/bin/bash\n"
"roye:x:502:502::/home/roye:/bin/bash\n"
"ecnet:x:503:503::/var/www/html:/bin/bash\n"
"phoebe:x:504:504::/home/phoebe:/bin/bash")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.