re = /^[^,]+(?:,\s*Esq\.)?/m
str = 'Mr. Bob Smith, Esq., Fish Bowl Lane
Mr. Bob Smith, Fish Bowl Lane'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end