package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`n`)
var str = `string1
string2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}