re = /\|\|(.*?)\|\|/m
str = 'About ||PrimarySchool|| % of children in ||Country|| attend primary school. ||SecondarySchoolFemale|| % of girls and ||SecondarySchoolMale|| % of boys finish secondary school. Literacy is ||LiteracyFemale|| % for females and ||LiteracyMale|| % for males.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end