re = /^[^,\s]+(?:,\s*[^,\s]+)*/m
str = 'abacora (definition)
abacorar (definition)
abad, desa (definition)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end