using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\W)(xtext)";
string input = @".art text xtext gg
.fo xtext = U|xtext
dfgtx 'xtext' gghzu 'U|xtext'
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}