$re = '/^(\'[^\']*\'|"[^"]*")$/m';
$str = 'No quotes
"Double quoted"
\'Single quoted\'
"One of each\'
"Multi""quotes"
\'"\'"@";\'"*&^*\'\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);